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RELEASE NOTES

NI-IMAQ FOR WINDOWS 95/98/NT
NI-IMAQ for Windows 95/98/NT is the imaging acquisition software fo
all National Instruments IMAQ devices. The NI-IMAQ software is 
compatible with Windows 95, Windows 98, and Windows NT 4.0 or lat

These release notes describe how to install your NI-IMAQ software. A
included is information about upgrading from NI-IMAQ 1.x to 
NI-IMAQ 2.1. Please also see the readme.txt  file included with your 
software for the most up-to-date information about this release of 
NI-IMAQ.

Contents
NI-IMAQ Documentation.......................................................................
Software Components ...........................................................................
Installation Procedures..........................................................................
IMAQ Hardware Configuration..............................................................
LabVIEW/BridgeVIEW Compatibility

between NI-IMAQ 1.x and 2.x............................................................. 3
NI-IMAQ 1.x and 2.x Compatibility....................................................... 7
Custom LUT Function and VI Descriptions ...........................................
About the Online Manual Set.................................................................

NI-IMAQ Documentation
Your NI-IMAQ software documentation is online. Refer to the About the 
Online Manual Set section later in these notes for more information abo
using the online manuals.
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Software Components
Your NI-IMAQ software kit contains the following components:

❑ NI-IMAQ device driver software

❑ NI-IMAQ Microsoft Visual C/C++, Borland, Watcom, and Symante
import libraries

❑ NI-IMAQ VIs for G

❑ IMAQ Configuration Utility

❑ NI-IMAQ for Windows 95/98/NT installer

❑ NI-IMAQ sample code

❑ Online documentation

Installation Procedures
Insert the NI-IMAQ CD into your drive. An autorun screen will appear, 
shown in Figure 1.

Figure 1.  Initial Installer Screen
NI-IMAQ for Windows 95/98/NT Release Notes 2 © National Instruments Corporation
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Click on Install»NI-IMAQ 2.1  to launch the NI-IMAQ 2.1 installer and 
follow the instructions on the installation screens. You must install 
NI-IMAQ before installing your IMAQ hardware device.

Note You must have administrator access in Windows NT to perform the installation

The Install»IMAQ Vision Evaluation Software  option allows you to 
install evaluation versions of IMAQ Vision for LabVIEW, BridgeVIEW, 
LabWindows/CVI, and ComponentWorks. IMAQ Vision adds high-leve
machine vision and image processing functions to your application 
development environment.

The View»Release Notes and View»Online Documents options allow you 
to view the online documentation for NI-IMAQ 2.1 and your IMAQ device
These documents are provided in Adobe Acrobat portable document 
format (pdf). If you do not have Acrobat Reader installed on your syste
you will be prompted to install it using the installer provided on the CD

IMAQ Hardware Configuration
Configure and test your IMAQ hardware by running the IMAQ 
Configuration Utility. Refer to the set up and test document for your devic
and the IMAQ Configuration Utility online help for configuration, 
installation, and testing instructions.

LabVIEW/BridgeVIEW Compatibility 
between NI-IMAQ 1.x and 2.x

The NI-IMAQ VIs changed between NI-IMAQ 1.5 and 2.x to increase ease
of use and to add more functionality. The following changes were mad

• All VIs now have a IMAQ Refnum In  and IMAQ Refnum Out  
parameter. This is similar to the TaskID input/output used with the 
data acquisition VIs.

• The underscore has been removed from all VI names.

• Low-level acquisition VIs have been added. These VIs add more 
functionality such as asynchronous acquisitions, accessing buffers
during acquisition, ring acquisitions, and the ability to download 
custom look-up tables (LUTs) to your IMAQ device.

• Signal I/O VIs have been added. These VIs allow you to control trig
lines, generate specific timing pulses, and wait for a hardware eve
© National Instruments Corporation 3 NI-IMAQ for Windows 95/98/NT Release Notes
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High-Level VI Changes
IMAQ_Grab is now two VIs—IMAQ Grab Setup and IMAQ Grab 
Acquire. IMAQ Grab Setup starts the grab acquisition. IMAQ Grab 
Acquire returns a copy of the image currently in the buffer. You can us
IMAQ Close to stop the hardware acquisition.

IMAQ Sequence does not have a mode input, which required that you
the VI four times to perform a sequence acquisition. Instead, call IMAQ
Sequence once to set up the acquisition, perform the acquisition, and r
the acquired images.

IMAQ_1408 Setup Analog has been removed. IMAQ_1408 Setup Ana
allowed the white and black reference levels to be set in volts. Use the
IMAQ Attribute VI to achieve the same functionality. The White 
Reference Level and Black Reference Level attributes in NI-IMAQ 2.1 
are now set in volts instead of steps.

IMAQ_Snap Async has been removed because the functionality is now
provided in IMAQ Snap. IMAQ Snap is now asynchronous so that you c
use it with triggering.

IMAQ_Wait for Event has been changed to IMAQ Wait Signal. The IMA
Wait Signal VI has the same functionality as IMAQ_Wait for Event with
additions for the IMAQ PCI-1424.

IMAQ_Trigger Control has been replaced by three VIs. IMAQ Trigger 
Configure configures trigger lines to allow an acquisition to start on a 
trigger. IMAQ Trigger Drive drives a trigger line with a specified signal.
IMAQ Trigger Read reads the current value of a trigger line.

IMAQ_Trigger RTSI Map has been removed. The mapping of RTSI lin
is now handled internally by NI-IMAQ. If you specify a RTSI line when 
using the trigger VIs, NI-IMAQ internally maps the RTSI line on the RTS
bus to a RTSI trigger line on the IMAQ board.

IMAQ_Info has been removed. The same functionality is available with
IMAQ Attribute.

IMAQ_Channel has been removed. The acquisition VIs now have a 
channel input that allows you to select a channel on the IMAQ board.
NI-IMAQ for Windows 95/98/NT Release Notes 4 © National Instruments Corporation
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Compatibility VIs
All of the NI-IMAQ 1.5 VIs are available as compatibility VIs. They are
installed in the vi.lib/addons/imaq/compatibility  directory; 
however, they do not appear on the imaqview palette. These VIs allow you 
to load and run existing IMAQ applications without changing your code
You should replace your NI-IMAQ 1.5 VIs with NI-IMAQ 2.1 VIs at your
earliest convenience, because the compatibility VIs will not be included
future NI-IMAQ releases.

NI-IMAQ provides a tool that will convert some of the NI-IMAQ 1.x VIs 
to 2.1 VIs. Using this tool, you can convert the following VIs:

• IMAQ_Snap to IMAQ Snap

• IMAQ_Snap Async to IMAQ Snap

• IMAQ_Init to IMAQ Init

• IMAQ_Close to IMAQ Close

• IMAQ_Attribute to IMAQ Attribute

• IMAQ_StillColor Attribute to IMAQ StillColor Attribute

• IMAQ_StillColor Setup to IMAQ StillColor Setup

To use the conversion tool, launch lvimaq.exe , which is located in the 
<ni-imaq>/G compatibility  directory. This will launch a special 
version of LabVIEW that contains the conversion tool. Load your IMAQ
application. As your application loads, the appropriate NI-IMAQ VIs wi
be converted. After your VI loads, save it. You can now load the VI into
LabVIEW or BridgeVIEW and convert the VIs that were not converted.

Note This conversion tool will only work with LabVIEW 5.x or BridgeVIEW 2.x VIs. If 
you have an earlier version of LabVIEW or BridgeVIEW, do not use this tool.

The following table describes the corresponding NI-IMAQ 2.1 VI for ea
NI-IMAQ 1.x VI.
© National Instruments Corporation 5 NI-IMAQ for Windows 95/98/NT Release Notes



Table 1.  NI-IMAQ VI Equivalents

NI-IMAQ 1. x VI NI-IMAQ 2.1

IMAQ_Snap IMAQ Snap

IMAQ_Grab IMAQ Grab Setup, IMAQ Grab 
Acquire

IMAQ_Sequence IMAQ Sequence

IMAQ_Init IMAQ Init

IMAQ_Close IMAQ Close

IMAQ_Attribute IMAQ Attribute

IMAQ_1408 Setup Analog Removed (same functionality is 
available with IMAQ Attribute)

IMAQ_Snap Async Removed (IMAQ Snap provides 
the same functionality)

IMAQ_Wait for event IMAQ Wait Signal

IMAQ_Trigger Control IMAQ Trigger Configure replaces 
starting an acquisition on a trigger

IMAQ Trigger Drive replaces 
driving trigger lines

IMAQ Trigger Read replaces 
reading trigger lines

IMAQ_Trigger RTSI Map Removed (VIs will perform this 
functionality internally)

IMAQ_Info Removed (same functionality is 
available with IMAQ Attribute)

IMAQ_Channel Removed (acquisition VIs now 
have channel input)
NI-IMAQ for Windows 95/98/NT Release Notes 6 © National Instruments Corporation
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NI-IMAQ 1.x and 2.x Compatibility
The following changes have been made to NI-IMAQ:

• Functions

– imgSessionSetTrigger  has been replaced 
with imgSessionTriggerConfigure  
andimgSessionTriggerDrive.  
imgSessionTriggerConfigure  configures a trigger to start an
acquisition. ImgSessionTriggerDrive  drives a trigger with a 
specified signal. ImgSessionSetTrigger  is still supported; 
however, you should use the new trigger functions.

– imgSessionSaveBuffer  has been replaced with 
imgSessionSaveBufferEx , which takes a buffer pointer 
instead of a buffer number to determine which buffer to save 
to file.

– New LUT functions, imgSessionSetUserLUT8bits  and 
imgSessionSetUserLUT16bits , allow you to download 
custom LUTs to your IMAQ device. See the Custom LUT 
Function and VI Descriptions section for more information on 
these new functions.

• Camera attributes

– The camera attributes allow you to control camera functions, s
as integration time and pixel binning, directly from NI-IMAQ 
with the IMAQ PCI-1424. Consult the Camera Attributes section 
in the NI-IMAQ User Manual for more information.

• Attributes

– IMG_ATTR _WHITE_REF, IMG_ATTR _BLACK_REF, and 
IMG_ATTR_GAIN have been replaced by 
IMG_ATTR_BLACK_REF_VOLT and 
IMG_ATTR_WHITE_REF_VOLT. This allows you to set the 
black and white reference in volts instead of steps.

– IMG_ATTR_LUT is now a session attribute instead of an 
interface attribute.

– IMG_ATTR_FRAME_FIELD is now a session attribute instead
of an interface attribute.

– IMG_ATTR_INTERFACE_TYPE has been removed.
© National Instruments Corporation 7 NI-IMAQ for Windows 95/98/NT Release Notes
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Custom LUT Function and VI Descriptions
This section describes the two new custom LUT functions and the new
custom LUT G VI.

imgSessionSetUserLUT8bits Function
rval = imgSessionSetUserLUT8bits (SESSION_ID sid, uInt32 lutType, uInt8* lut)

Purpose
Downloads a custom 8-bit LUT to your IMAQ device. If your camera has more than one L
you must program all of them. Call this function at least once with the default constant
(IMG_LUT_TYPE_DEFAULT) to initialize all LUTs, or make successive calls using 
different constants for each LUT. You can also override the default LUT on a per-tap ba
This function works with analog IMAQ devices or digital cameras with 8-bit taps.

Parameters

Parameter Discussion
sid is a valid SESSION_ID type variable.

lutType indicates the type of LUT to be written. Valid values are:

IMG_LUT_TYPE_DEFAULT default LUT used to initialize all LUTs
IMG_LUT_TYPE_RED red channel LUT for RGB digital cameras
IMG_LUT_TYPE_GREEN green channel LUT for RGB digital cameras
IMG_LUT_TYPE_BLUE blue channel LUT for RGB digital cameras
IMG_LUT_TYPE_TAP0 tap 0 LUT for digital boards
IMG_LUT_TYPE_TAP1 tap 1 LUT for digital boards
IMG_LUT_TYPE_TAP2 tap 2 LUT for digital boards
IMG_LUT_TYPE_TAP3 tap 3 LUT for digital boards

lut  points to an area of memory that contains the LUT to be downloaded to the image 
acquisition board. This array must contain 256 elements.

Name Type Direction Description

sid SESSION_ID input session ID

lutT ype uInt32 input LUT to be downloaded

lut uInt8* input pointer to user buffer 
containing the LUT

rval Int32 output no error
NI-IMAQ for Windows 95/98/NT Release Notes 8 © National Instruments Corporation
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rval  returns the following status codes:

IMG_ERR_GOOD no error

IMG_ERR_PAR1 invalid session ID
IMG_ERR_PAR2 unknown LUT type
IMG_ERR_PAR3 null buffer passed as LUT
IMG_ERR_EMEM not enough memory to perform the operation
IMG_ERR_HWNC the board does not support this LUT type

ImgSessionSetUserLUT16bits Function
rval = imgSessionSetUserLUT16bits (SESSION_ID sid, uInt32 lutType, uInt16* lut)

Purpose
Downloads a custom 16-bit LUT to your IMAQ device. If your camera has more than o
LUT, you must program all of them. Call this function at least once with the default cons
(IMG_LUT_TYPE_DEFAULT) to initialize all LUTs, or make successive calls using 
different constants for each LUT. You can also override the default LUT on a per-tap ba
This function works with digital cameras of 10-, 12-, 14-, or 16-bit pixel depths.

Parameters

Parameter Discussion
sid is a valid SESSION_ID type variable.

lutType indicates the type of LUT to be written. Valid values are:
IMG_LUT_TYPE_DEFAULT default LUT used to initialize all LUTs
IMG_LUT_TYPE_TAP0 tap 0 LUT for digital boards
IMG_LUT_TYPE_TAP1 tap 1 LUT for digital boards

lut  points to an area of memory that contains the LUT to be downloaded to the IMAQ de
This array must contain 2n elements where n is the bit depth of the camera (1,024 for 10-bi
cameras, 2,048 for 12-bit cameras, and so on).

Name Type Direction Description

sid SESSION_ID input session ID

lutT ype uInt32 input LUT to be downloaded

lut uInt6* input pointer to user buffer 
containing the LUT

rval Int32 output no error
© National Instruments Corporation 9 NI-IMAQ for Windows 95/98/NT Release Notes
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rval  returns the following status codes:
IMG_ERR_GOOD no error
IMG_ERR_PAR1 invalid session ID
IMG_ERR_PAR2 unknown LUT type
IMG_ERR_PAR3 null buffer passed as LUT
IMG_ERR_EMEM not enough memory to perform the operation
IMG_ERR_HWNC the board does not support this LUT type

IMAQ Set User LUT VI

Downloads a custom LUT to an IMAQ device. This VI can download 8-bit or 16-bit LUT
for analog or digital devices. If your IMAQ device has multiple LUTs, you must call this
once for each LUT.

IMAQ Refnum In  is a unique identifier that identifies the Interface file. 
If you are using the default interface, img0 , no connection is needed.

Tap 0 LUT (Red) is used for analog monochrome devices, the red chan
for RGB digital cameras, or tap 0 on digital devices. If your device is 
an 8-bit device, wire an array of 8-bit unsigned integers containing 
256 elements. If your device is greater than 8-bits, wire an array of 16
unsigned integers containing 2n elements where n is the bit depth of the 
camera (1,024 for 10-bit, 2,048 for 12-bit, and so on).

Tap 1 LUT (Green) is used for the green channel for RGB digital camer
or tap 1 on digital devices. If your device is an 8-bit device, wire an arr
of 8-bit unsigned integers containing 256 elements. If your device is gre
than 8-bits, wire an array of 16-bit unsigned integers containing 2n elements 
where n is the bit depth of the camera (1,024 for 10-bit, 2,048 for 12-bi
and so on).

Tap 2 LUT (Blue) is used for the blue channel for RGB digital cameras 
tap 2 on digital devices. If your device is an 8-bit device, wire an array
8-bit unsigned integers containing 256 elements. 
NI-IMAQ for Windows 95/98/NT Release Notes 10 © National Instruments Corporation
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Tap 3 LUT is used for tap 3 on digital devices. If your device is an 8-b
device, wire an array of 8-bit unsigned integers containing 256 elemen

IMAQ Refnum Out  has the same value as IMAQ Refnum In .

See Appendix C, Error Codes, of the NI-IMAQ VI User Manual for error 
input and output information and error codes.

About the Online Manual Set
The IMAQ hardware and software documentation set ships with your 
software as Adobe Acrobat portable document format (PDF) files. 

To view one of these documents, double-click on the DocList.pdf  file, 
located in the Documents  folder on your NI-IMAQ CD. Click on any 
document name to launch the document you want to view.

Note If you do not already have Acrobat Reader installed on your system, the instal
will create a new directory, <target install dir>\ACROREAD , and insert the 
Adobe Acrobat Installer into it. Run this installer before viewing your online 
documentation. You must have Acrobat Reader 3.0 or later installed to use the
online documentation.

Using the NI-IMAQ Online Manual Set
The NI-IMAQ software online help and PDF documentation also is 
installed onto your hard drive with the NI-IMAQ software.

To view the online help, click the Start button on the taskbar, point to 
Start»Programs»National Instruments IMAQ and choose either 
NI-IMAQ Function Help  or NI-IMAQ VI Help .

To view the PDF documents, click the Start button on the taskbar, point to
Start»Programs»National Instruments IMAQ»Documentation, and 
choose the appropriate document. This will automatically launch the 
Acrobat Reader and open the selected PDF file. You can assemble yo
own printed manuals by printing either the entire documentation set or o
the sections relevant to your application.

Click on any entry in the table of contents to jump directly to that page
You can jump to major sections within each document quickly and eas
by clicking on the bookmarks.

When you choose the View»Go To Page... option or are printing pages, 
you must use the page numbers in the lower left corner of the Acrobat
window, not the number displayed at the bottom center of each manua
page or listed in the contents and index. The PDF files are electronic 
© National Instruments Corporation 11 NI-IMAQ for Windows 95/98/NT Release Notes
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equivalents of printed manuals. However, unlike printed manuals, the P
file assigns consecutive numbers to each page throughout the documen
displays this page number. These numbers may not match those show
the bottom center of each manual page.

You can use Acrobat Reader to quickly find and go to every occurrenc
any word or phrase in the entire document. Simply select the Tools»Find... 
option and type in the key word or phrase you want to find.
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